centos6升级python2.7并安装pip

前言

最近因为买服务器去翻墙,结果系统选的是centos6,通过https://www.aihoom.com/741.html这篇文章搭建的SS发现居然安装shadowsock居然出现失败,检查了下原因是因为python2.6已经不再支持安装...

如果你想搭建翻墙服务,本博客将会在后更新关于SS后端操控。如果你没找到合适的VPS 请参考https://www.aihoom.com/586.html

开始

  • 1.安装依赖

yum groupinstall "Development tools"

yum install zlib-devel bzip2-devel openssl-devel ncurses-devel sqlite-devel

  • 2.下载安装Python2.7

以下步骤依次运行

wget https://www.python.org/ftp/python/2.7.11/Python-2.7.11.tgz
tar vxf Python-2.7.11.tgz
cd Python-2.7.11
./configure --prefix=/usr/local
make && make install

 

Last modification:March 16th, 2017 at 09:38 pm
If you think my article is useful to you, please feel free to appreciate

Leave a Comment